latest beta 3.2.9 download here [Updated 21/11]

discussions about ConvertXtoDVD latest versions, avi to dvd video converter software, burns videos from your PC to watch on your DVD with menus and subtitles.

Moderators: Maggie, Cougar_II, ckhouston, JJ, Forum admin

User avatar
lapinou
Posts: 449
Joined: Tue Aug 22, 2006 2:04 pm
Location: France
Contact:

latest beta 3.2.9 download here [Updated 21/11]

Post by lapinou » Sun Nov 16, 2008 12:25 pm

Hi

here is the current ConvertXtoDVD beta 3.2.9.94c version :

http://download.vso-software.fr/vsoConv ... .9.94c.exe

before posting problems in the forum, please give it a try and confirm if you have still your problem with this one or if it has been fixed.

Change log / history of changes :

ConvertXtoDVD - 3.2.9.94c
========================
- a few translation updated
- fix a corruption of the verisign certificated during the compilation of the installer

ConvertXtoDVD - 3.2.9.94
========================

yet another bugfixes

- 0001909: [Bug] Wrong duration of subtitle file lenghth displayed at treeview. (wesson) - resolved.
- 0001968: [Bug] Preview is showing you the wrong menu, after YES apply the changes to your current project (wesson) - resolved.
- 0001984: [Bug] v3.1.3.36 ßeta: When converting minimized, Building Current Title Window still appears (wesson) - resolved.
- 0001988: [Bug] Wrong text in title menu button (only in preview window) (wesson) - resolved.
- 0002411: [Bug] Warning File "00001.MTS" has invalid Timestamps. build 3.2.8.92 (wesson) - resolved.
- 0002074: [Information] Black Mirror Template - 'Background text in Audio/Subtitle settings menu - Use Template default' (wesson) - resolved.
- 0002215: [Bug] convertion problem with build 3.2.1.54 in a movie file (wesson) - resolved.
- 0002345: [Suggestion] Load interface, then load menu templates (wesson) - resolved.

ConvertXtoDVD - 3.2.8.92
========================

Various bugfixes

- 0002234: [Bug] Offset of Video and Audio (for sync) does not work in 3.2.1.55. (wesson) - resolved.
- 0002343: [Crash] Version 3.2.2.76 (wesson) - resolved.
- 0002346: [Bug] access violation, at end of completed conversion (wesson) - resolved.
- 0002364: [Bug] Not all detailed source file info shown at tree view(source file info node) (wesson) - resolved.
- 0002406: [Crash] Crash,access violation, invalid pointer (wesson) - resolved.
- 0002408: [Bug] 3.2.7.88 regression on ass subtitle file (wesson) - resolved.

- Include burning SDK 3.1.1
- updated translations ( Chinese, etc.. )


ConvertXtoDVD - 3.2.7.90
========================
- fix problem when unicode files are loaded

ConvertXtoDVD - 3.2.7.89
========================
- fix crashes when loading and saving project

ConvertXtoDVD - 3.2.7.88
========================
- ffmpeg compiler updated
- ffmpeg reference updated
- gdiplus.dll distributed is the reference version of Microsoft

ConvertXtoDVD - 3.2.6.86
========================
Interface fixes (save windows position and state)
Some audio out of sync fixes

- 0002294: [Feature Request] Option to save window size/positioning (wesson) - resolved.
- 0002276: [Bug] Window sizes and location not saved in registry (wesson) - resolved.
- 0002367: [Bug] Checkboxes not visible with Eos theme (wesson) - resolved.
- 0002369: [Bug] Burner Selection under Settings (wesson) - resolved.
- 0002402: [Bug] V84. Manual entered value at crop/pad at window resize method not correct when first char. is odd (1, 3, 5, 7 ,9) (wesson) - resolved.
- 0002405: [Feature Request] add pop up 'thanks for registering' (wesson) - resolved.
- 0002391: [Bug] Out of sync on audio with some FLV movie file (wesson) - resolved.
- 0002390: [Bug] Out of sync on audio with some WMV files (wesson) - resolved.
- 0002243: [Bug] Some MPEG Files makes convertxtodvd non responding, at the beginning of the conversion. (wesson) - resolved.
- 0002399: [Crash] memory error loop during conversion (wesson) - resolved.
- 0002400: [Bug] v3.2.5.84 ßeta: Settings does not keep our burner choice. (wesson) - resolved.
- 0002401: [Suggestion] Fix the column width for the log window (wesson) - resolved.

- Include Burning SDK 3.1

ConvertXtoDVD - 3.2.5c
========================
- Update translation and english reference
- updated subtitles dialog ( preview of subtitle over the tooltip of the code page button )
- fix a problem with audio output when the input format is mpeg mono.
- fix some issues with source containing AC3 3 or 4 channels.
- various fixes.


Also if you have still the problem and wish to use and confirm the problem isn't there with the older version, please post the confirmation the version .55 doesn't have the problem. You can download the OLD stable version here :

http://download2.vso-software.fr/vsoCon ... _old55.exe
Last edited by lapinou on Tue Nov 25, 2008 11:52 am, edited 8 times in total.

Ianpb
Posts: 3
Joined: Mon Jun 02, 2008 1:36 pm

Post by Ianpb » Thu Nov 20, 2008 3:25 am

A constructive suggestion.

It might be helpful to list modifications applied to new versions to check whether particular issues have been addressed.

User avatar
lapinou
Posts: 449
Joined: Tue Aug 22, 2006 2:04 pm
Location: France
Contact:

Post by lapinou » Thu Nov 20, 2008 7:59 am

it would have make sense, but the public list of changes isn't detailed enough to explain any problem. finally we found the main problem was due to a faulty external component memory corruption, if the project load or save is used during the session.

User avatar
efex172
Posts: 665
Joined: Wed May 30, 2007 1:05 am
Location: Somewhere Dark

Post by efex172 » Thu Nov 20, 2008 7:20 pm

You could package the releases in zip/rar..etc file with a text file of the changes to the beta group
There's an old android saying which I feel is particularly relevant to this situation. It goes '00101010110100101010011110' which, roughly translated, means 'Don't stand around jabbering when your life is in danger.. Kryten, Red Dwarf
READ STICKIES!

djstx2003
Posts: 67
Joined: Thu Dec 27, 2007 6:13 am

Post by djstx2003 » Thu Nov 20, 2008 8:02 pm

hi, i have a problem with new build 92. i loaded .MTS video files but have this warning. here's my log:


2008-11-20 21:58:25 Warning File "00003.MTS" has invalid Timestamps. A frame rate of 25,00 Fps will be used
2008-11-20 21:58:21 Warning File "00002.MTS" has invalid Timestamps. A frame rate of 25,00 Fps will be used
2008-11-20 21:58:17 Warning File "00001.MTS" has invalid Timestamps. A frame rate of 25,00 Fps will be used
2008-11-20 21:58:12 Warning File "00000.MTS" has invalid Timestamps. A frame rate of 25,00 Fps will be used
2008-11-20 21:57:47 Info 34 Menu templates loaded.
2008-11-20 21:57:47 Info BURN: 1 writer(s) found.
2008-11-20 21:57:47 Info BURN: Loaded DLL "C:\Program Files (x86)\VSO\ConvertX\3\vso_hwe.dll" [3.1.1.389]
2008-11-20 21:57:47 Info BURN: Compatible media types : DVD-R, DVD-RW Seq., DVD-RW RO, DVDRAM, DVD+R, DVD+RW, CD-R, CD-RW, DL DVD+R, DL DVD-R
2008-11-20 21:57:47 Info BURN: Drive has Serial ATA physical interface
2008-11-20 21:57:47 Info BURN: New Drive selected : 2:0:0 - PLEXTOR DVDR PX-810SA 1.01 [G] (Ide)
2008-11-20 21:57:47 Info BURN: Using SPTI interface
2008-11-20 21:57:46 Info Supported instruction set: sse4
2008-11-20 21:57:46 Info Tuning Performances for Intel(R) Core(TM)2 Extreme CPU X9650 @ 3.00GHz with 4 core(s) CPU
2008-11-20 21:57:46 Info System default language : Ελληνικά (Ελλάδας)
2008-11-20 21:57:46 Info User default language : Ελληνικά (Ελλάδας)
2008-11-20 21:57:46 Info Version : 3.2.8.92
2008-11-20 21:57:46 Info ExeName : C:\Program Files (x86)\VSO\ConvertX\3\ConvertXtoDvd.exe
2008-11-20 21:57:46 Info OS : Microsoft Vista Professional (build 6001) with Service Pack 1 6.0
2008-11-20 21:57:46 ---- ******************** Log session start 2008-11-20 21:57:46.036 PID 6076********************


thank you!!!

djstx2003

Spiros(Greece)

i already posted it to the bugs here:
http://bugs.vso-software.fr/view.php?id=2411
Last edited by djstx2003 on Thu Nov 20, 2008 8:32 pm, edited 1 time in total.

User avatar
lapinou
Posts: 449
Joined: Tue Aug 22, 2006 2:04 pm
Location: France
Contact:

Post by lapinou » Thu Nov 20, 2008 8:04 pm

I have copied / pasted the changes in the top message with the link.

djstx2003
Posts: 67
Joined: Thu Dec 27, 2007 6:13 am

Post by djstx2003 » Fri Nov 21, 2008 6:05 pm

djstx2003 wrote:hi, i have a problem with new build 92. i loaded .MTS video files but have this warning. here's my log:


2008-11-20 21:58:25 Warning File "00003.MTS" has invalid Timestamps. A frame rate of 25,00 Fps will be used
2008-11-20 21:58:21 Warning File "00002.MTS" has invalid Timestamps. A frame rate of 25,00 Fps will be used
2008-11-20 21:58:17 Warning File "00001.MTS" has invalid Timestamps. A frame rate of 25,00 Fps will be used
2008-11-20 21:58:12 Warning File "00000.MTS" has invalid Timestamps. A frame rate of 25,00 Fps will be used
2008-11-20 21:57:47 Info 34 Menu templates loaded.
2008-11-20 21:57:47 Info BURN: 1 writer(s) found.
2008-11-20 21:57:47 Info BURN: Loaded DLL "C:\Program Files (x86)\VSO\ConvertX\3\vso_hwe.dll" [3.1.1.389]
2008-11-20 21:57:47 Info BURN: Compatible media types : DVD-R, DVD-RW Seq., DVD-RW RO, DVDRAM, DVD+R, DVD+RW, CD-R, CD-RW, DL DVD+R, DL DVD-R
2008-11-20 21:57:47 Info BURN: Drive has Serial ATA physical interface
2008-11-20 21:57:47 Info BURN: New Drive selected : 2:0:0 - PLEXTOR DVDR PX-810SA 1.01 [G] (Ide)
2008-11-20 21:57:47 Info BURN: Using SPTI interface
2008-11-20 21:57:46 Info Supported instruction set: sse4
2008-11-20 21:57:46 Info Tuning Performances for Intel(R) Core(TM)2 Extreme CPU X9650 @ 3.00GHz with 4 core(s) CPU
2008-11-20 21:57:46 Info System default language : Ελληνικά (Ελλάδας)
2008-11-20 21:57:46 Info User default language : Ελληνικά (Ελλάδας)
2008-11-20 21:57:46 Info Version : 3.2.8.92
2008-11-20 21:57:46 Info ExeName : C:\Program Files (x86)\VSO\ConvertX\3\ConvertXtoDvd.exe
2008-11-20 21:57:46 Info OS : Microsoft Vista Professional (build 6001) with Service Pack 1 6.0
2008-11-20 21:57:46 ---- ******************** Log session start 2008-11-20 21:57:46.036 PID 6076********************


thank you!!!

djstx2003

Spiros(Greece)

i already posted it to the bugs here:
http://bugs.vso-software.fr/view.php?id=2411

in build 93 no warning about this, only this:
File "00001.MTS" has a non monotonous timestamp. A frame rate of 25,00 Fps will be used.

but i think its ok.

thank you.

User avatar
lapinou
Posts: 449
Joined: Tue Aug 22, 2006 2:04 pm
Location: France
Contact:

Post by lapinou » Fri Nov 21, 2008 6:38 pm

yes actually there is a real inconsistency in the file, but it doesn't have a true consequence, that's why it is only an information now.

User avatar
Finnius
Posts: 39
Joined: Sat May 26, 2007 4:31 pm

Post by Finnius » Sat Nov 22, 2008 2:25 am

Ya, i have a serious problem. I just updated to the latest build and now i get a message saying it cant find my DVD drive...AND in the dropdown, there are NO other choices other than "ISO Image in working folder"...I had NO problems the other day when i was using Cx2DVD...and i have done NO hardware/software/driver changes whatsoever..also i have not installed ANY new programs...

Image

User avatar
Finnius
Posts: 39
Joined: Sat May 26, 2007 4:31 pm

Post by Finnius » Sat Nov 22, 2008 2:47 am

sorry forgot to tell you that i was using Version : 3.2.3.81 before the update...also i have included my logfile from the past month for your amusement...
Attachments
ConvertXtoDVD logfile.txt
(292.04 KiB) Downloaded 397 times

GEORGIEBOY26
Posts: 131
Joined: Sat Nov 22, 2008 1:52 pm

Post by GEORGIEBOY26 » Sat Nov 22, 2008 1:56 pm

Finnius wrote:sorry forgot to tell you that i was using Version : 3.2.3.81 before the update...also i have included my logfile from the past month for your amusement...

i had similar prob, but found closing the prog and restarting it found my dvd drive, it was a glitch i think

User avatar
lapinou
Posts: 449
Joined: Tue Aug 22, 2006 2:04 pm
Location: France
Contact:

Post by lapinou » Sat Nov 22, 2008 3:56 pm

it would be interesting to know how to reproduce the problem, maybe the drive was busy because you just inserted or ejected a disc before starting the program ? or maybe another program such Anydvd or DVD43 is in-use ?

User avatar
Cougar_II
VSO Fanatic
Posts: 4840
Joined: Wed Apr 04, 2007 7:35 pm
Location: Québec, Canada

Post by Cougar_II » Sat Nov 22, 2008 4:38 pm

Hi,

Several people are having issues with burners missing from ConvertXtoDVD or from DVDFab (which uses VSO's Burn SDK)

It seems the last working version (Burn Engine) for everyone is

vso-hwe.dll (v3.0.2.382)

An official bug report with a high priority was opened by myself with all your details:

http://bugs.vso-software.fr/view.php?id=2417
VSO Software Golden Membership Proud Owner / VSO Software Beta Tester
Image

User avatar
Finnius
Posts: 39
Joined: Sat May 26, 2007 4:31 pm

Post by Finnius » Sat Nov 22, 2008 5:58 pm

ok so i did a complete uninstall of ConvertX thru Control Panel. Then i installed an OLD version 3.0.0.16...It found my drive immediately...Went to the update site...d/l to my computer. Ran it, and poof...no drive recognition again...it MUST be the latest build..as i reported earlier everything was fine with build 3.2.3.81. As for the drive being busy, NO. There was nothing in the drive. The only program i had running besides ConvertX was MS Messenger.

2008-11-22 12:53:16 Info 39 Menu templates loaded.
2008-11-22 12:53:16 Info Version is up to date
2008-11-22 12:53:14 Warning BURN: No writer found. Only ISO image destination is available
2008-11-22 12:53:14 Info BURN: Loaded DLL "C:\Program Files\VSO\ConvertX\3\vso_hwe.dll" [3.1.1.389]
2008-11-22 12:53:14 Info BURN: Using Patin-Couffin driver Version 1.37, Internal revision 37 Async. Access mode
2008-11-22 12:53:14 Info Supported instruction set: sse2
2008-11-22 12:53:14 Info Tuning Performances for Intel(R) Pentium(R) 4 CPU 3.20GHz with 2 logical core(s)
2008-11-22 12:53:14 Info System default language : English (United States)
2008-11-22 12:53:14 Info User default language : English (United States)
2008-11-22 12:53:14 Info Version : 3.2.9.94
2008-11-22 12:53:14 Info ExeName : C:\Program Files\VSO\ConvertX\3\ConvertXtoDVD.exe
2008-11-22 12:53:14 Info OS : Microsoft Vista Professional (build 6002) with Service Pack 2, v.105 6.0
2008-11-22 12:53:11 ---- ******************** Log session start 2008-11-22 12:53:11.000 PID 760********************


11/22/2008 12:52:26 PM info ********** Report session closed ***********
11/22/2008 12:51:44 PM info Newer version (3.2.4.82) is available on internet
11/22/2008 12:51:24 PM info Newer version (3.2.4.82) is available on internet
11/22/2008 12:51:18 PM info 31 Menu templates loaded.
11/22/2008 12:51:17 PM info BURN: Using Patin-Couffin driver Version 1.37, Internal revision 37 - Async. Access mode
11/22/2008 12:51:16 PM info Supported instruction set: sse2
11/22/2008 12:51:16 PM info Tuning Performances for Intel(R) Pentium(R) 4 CPU 3.20GHz with 2 logical core(s)
11/22/2008 12:51:16 PM info User default language : 1033 (0x0409h) - English (United States)
11/22/2008 12:51:16 PM info System default language : 1033 (0x0409h) - English (United States)
11/22/2008 12:51:16 PM info Version 3.0.0.16
11/22/2008 12:51:16 PM info ExeName : "C:\Program Files\VSO\ConvertX\3\ConvertXtoDvd.exe"
11/22/2008 12:51:16 PM info OS : Microsoft Vista Professional Service Pack 2, v.105 (Build 6002)
11/22/2008 12:51:14 PM info ******************** Report session started ********************

User avatar
Finnius
Posts: 39
Joined: Sat May 26, 2007 4:31 pm

Post by Finnius » Sat Nov 22, 2008 6:14 pm

Update: did full uninstall and installed 3.2.1.55. I am leaving it alone at this point.

1. Cougar: thanks for doing the Bug report, i was going to do it today but you beat me to it :)

2. Lapinou: I got your PM and have responded. I will have Messenger up all day if you want to try out some things.

Gianni45
Posts: 19
Joined: Tue Oct 23, 2007 8:36 am

Post by Gianni45 » Sat Nov 22, 2008 6:15 pm

Finnius wrote:Ya, i have a serious problem. I just updated to the latest build and now i get a message saying it cant find my DVD drive...
i believe that issue may be OS related...i can see you're on Vista but NO problem with missing burners for me running v3.2.9.94 on XP SP2 :idea:

User avatar
hansK
VSO Fanatic
Posts: 2516
Joined: Mon Mar 17, 2008 10:22 pm
Location: Netherlands

Post by hansK » Sat Nov 22, 2008 6:24 pm

Hi all,
Finnius wrote:
Ya, i have a serious problem. I just updated to the latest build and now i get a message saying it cant find my DVD drive...


i believe that your issue may be OS related...i can see you're on Vista but NO burn problem for me running v3.2.9.94 on XP SP2 Idea
On my PC (internal burner) V94 no prblem.
I did even 3 burns with including burner program.
Running OS: XP Professional SP2

My PC has same processor type as Finnius.

Part of my log:
2008-11-22 15:43:02 ---- **************** Burn settings begin ****************
2008-11-22 15:33:18 Info BURN: WRITE SUCCESS: Disc written
2008-11-22 15:33:18 Info BURN: Finalization Time 00:00:29 - Total completion time 00:04:26
2008-11-22 15:32:48 Info BURN: Write finished in 00:03:56 - Finalization start here. Avg. burn rate 4,39
2008-11-22 15:28:52 Info BURN: Lead-in burning time (mS) 0
2008-11-22 15:28:52 Info BURN: Write started 639472 sectors to write
2008-11-22 15:28:52 Info BURN: Init success: DVD+RW
2008-11-22 15:28:52 Info BURN: Writing speed requested x4.0, effective x4.0
2008-11-22 15:28:52 Info BURN: Format completed
2008-11-22 15:28:26 Info BURN: Format start
2008-11-22 15:28:26 Info BURN: Available write speed: 4x, 2.4x,
2008-11-22 15:28:26 Info BURN: Media ID: RITEK-004-00
2008-11-22 15:28:26 Info BURN: Media type: DVD+RW
2008-11-22 15:28:26 Info BURN: Ultra DMA mode 4 (ATA66)
2008-11-22 15:28:24 Info BURN: Scanned files #8, folder #2 - total size 1308516352 b. (1,22 Gb.)
2008-11-22 15:28:24 Info BURN: Inserted media type : DVD+RW
2008-11-22 15:28:24 Info BURN: Write started
2008-11-22 15:28:24 Info Disc name: "Kung.Fu.Panda-Secrets.Of.The.Fur"
2008-11-22 15:28:24 Info Burned folder: "E:\Mijn werken\Kung.Fu.Panda-Secrets.Of.The.Furious.Five[2008]DvDrip-aXXo\VIDEO_TS"
2008-11-22 15:28:21 Info BURN: New media (DVD+RW) inserted. Burning layer is ready to write
2008-11-22 15:28:19 Info BURN: Compatible media types : DVD-R, DVD-RW Seq., DVD-RW RO, DVDRAM, DVD+R, DVD+RW, CD-R, CD-RW, DL DVD+R, DL DVD-R
2008-11-22 15:28:19 Info BURN: Drive has IDE-ATAPI physical interface
2008-11-22 15:28:19 Info BURN: New Drive selected : 1:0:0 - ASUS DRW-1608P3S 1.24 [L] (Ide)
2008-11-22 15:28:04 Info 34 Menu templates loaded.
2008-11-22 15:28:00 Info BURN: New media (DVD+RW) inserted. Burning layer is ready to write
2008-11-22 15:27:58 Info BURN: 1 brander(s) gevonden.
2008-11-22 15:27:58 Info BURN: Geladen DLL "C:\Program Files\VSO\ConvertX\3\vso_hwe.dll" [3.1.1.389]
2008-11-22 15:27:58 Info BURN: Compatible media types : DVD-R, DVD-RW Seq., DVD-RW RO, DVDRAM, DVD+R, DVD+RW, CD-R, CD-RW, DL DVD+R, DL DVD-R
2008-11-22 15:27:58 Info BURN: Drive has IDE-ATAPI physical interface
2008-11-22 15:27:58 Info BURN: New Drive selected : 1:0:0 - ASUS DRW-1608P3S 1.24 [L] (Ide)
2008-11-22 15:27:58 Info BURN: Using Patin-Couffin driver Version 1.37, Internal revision 37 Async. Access mode
2008-11-22 15:27:57 Info Supported instruction set: sse2
2008-11-22 15:27:57 Info Tuning Performances for Intel(R) Pentium(R) 4 CPU 3.00GHz with 2 logical core(s)
2008-11-22 15:27:57 Info System default language : Nederlands (Nederland)
2008-11-22 15:27:57 Info User default language : Nederlands (Nederland)
2008-11-22 15:27:57 Info Version : 3.2.9.94
2008-11-22 15:27:57 Info ExeName : C:\Program Files\VSO\ConvertX\3\ConvertXtoDvd.exe
2008-11-22 15:27:57 Info OS : Microsoft Windows XP Professional (build 2600) with Service Pack 2 5.1
2008-11-22 15:27:38 ---- ******************** Log session start 2008-11-22 15:27:38.296 PID 5412********************

Regards,
hansK

User avatar
Finnius
Posts: 39
Joined: Sat May 26, 2007 4:31 pm

Post by Finnius » Sat Nov 22, 2008 6:28 pm

Gianni45 wrote:
Finnius wrote:Ya, i have a serious problem. I just updated to the latest build and now i get a message saying it cant find my DVD drive...
i believe that issue may be OS related...i can see you're on Vista but NO problem with missing burners for me running v3.2.9.94 on XP SP2 :idea:
That may be...but only testing will discover the cause
Last edited by Finnius on Sat Nov 22, 2008 6:30 pm, edited 1 time in total.

User avatar
toaddub
Posts: 781
Joined: Sat Jan 26, 2008 8:18 am

Post by toaddub » Sat Nov 22, 2008 6:29 pm

I think the problem applies to detention of external burners only. I don't have a problem either as I have 2 internal burners and running XP Pro SP3. Don't know if other users having problem are running Vista or not.

User avatar
hansK
VSO Fanatic
Posts: 2516
Joined: Mon Mar 17, 2008 10:22 pm
Location: Netherlands

Post by hansK » Sat Nov 22, 2008 6:42 pm

Hi Finnius,

I see from your log that you end up with 39 templates after a uninstall>install.

I had this also when going from V55 to newer.
This was because the uninstall did not delete all files in the folders.

I did a uninstall, and used additional windows explorer to remove all non-removed folders/files.
The folder Convertx should no longer exist in/at:
C;/Program files/vso

Then i did a reboot.
installed latest version.
registered with my key.

Since this moment i have the 34 included templates and had no major problems with the software(except for some reported bugs) regarding burn problems / seeing my internal burner.

Give this a try.
Takes 10 minutes to do.

Regards,
hansK

Post Reply