No Audible Sound Dolby True HD/Atmos

Convert to HD, convert Blu-ray , blu-ray menu, Burn bluray disks, create blu-ray disk, create AVCHD, Create custom blu-ray disk with menu

Moderators: Maggie, ckhouston, JJ, Phil, Forum admin

Post Reply
Posts: 106
Joined: Sun Oct 09, 2011 2:52 pm

No Audible Sound Dolby True HD/Atmos

Post by Nemesh »

Have here the movie 'The Irishman'.
From BDInfo 7.5.5:

Length: 3:29:04.532
Video: MPEG-4 AVC Video / 0 kbps / 1080p / 23.976 fps / 16:9 / High Profile 4.1
Audio: English / Dolby TrueHD/Atmos Audio / 7.1 / 48 kHz / 24-bit (AC3 Embedded: 5.1 / 48 kHz / 448 kbps / DN -28dB)
Audio: English / Dolby Digital Audio / 2.0 / 48 kHz / 192 kbps / DN -31dB / Dolby Surround
Subtitle: English / 0.000 kbps

I have created a movie-only from this one with my own subtitles.
Then created a very sinple menu: Backround, Menu Sound and only the play-button.
In simulation-mode everything works fine.
But after conversion there is No Audible Sound.
This happens with version and

Then as a experiment I removed the movie 'The Irishman' and add the movie 'Semper Fi'.
So the menu stays the same and Semper Fi has DTS-HD MA 5.1 audio.
Did a conversion and everything worked fine.

Except for the subtitle, setting for video and audio: Try to copy only if the source is a complient structure.
And also in the menu-options: Skip Intro- and Outro-menu
Can't ConvertXtoHD handle Dolby TrueHD/Atmos Audio 7.1?
Did the same with TsMuxer (latested nightly build) and it worked fine.


Posts: 33
Joined: Mon Nov 02, 2020 2:16 am

Re: No Audible Sound Dolby True HD/Atmos

Post by DSperber »

What do your LOGs for the two experiments show, for video and audio processing?

The log indicates whether your audio was either:

(a) determined to be compliant and resulted in a REMUX-ONLY raw copy of audio for the conversion to BluRay, or
(b) was determined to be non-compliant and resulted in a RE-ENCODE of input to output for audio.

Specifically, for (a) REMUX-ONLY processing mode the log should show something like the following:


While for (b) RE-ENCODE processing mode the log will instead show something like the following:


I believe this mode of XtoHD processing shown in the log is the key indicator for this new "no audible sound" in the output symptom when trying Note that when I forced the alternative RE-ENCODE processing mode using, I DID GET AUDIBLE SOUND in the output. Only REMUX failed to produce sound. RE-ENCODE worked fine.

Note also that I myself did not see this symptom occur when using the previous and also running in remux-mode, everything else for the experiment being the same. For me it was something newly introduced in but only specifically when running in remux-mode, which suspiciously is exactly what VSO has specifically touched in to fix the "memory leak" bug when running in REMUX-ONLY mode.

For my own input file that I was using in the experiment, according to MediaInfo 20.09 (View -> Sheet), my input file has the following audio/video characteristics (which are BluRay-compliant and thus resulted in remux-only raw copy processing from XtoHD):


I believe "The Irishman" you are using has a Dolby Atmos audio track. And I believe this would be reported as a "bed" audio of Dolby TrueHD 7.1 as you show. Should be "compliant" and not require re-encoding.

So if XtoHD does recognize this as a "compliant" format using your setting and goes ahead and performs a "remux-only" process, your LOG would show the same "raw copy" as is shown in my log for my own experiment using my own "compliant" input file. The log would show that.

And if so, my hunch is that this is why you are also experiencing the exact same NO AUDIBLE SOUND symptom I also received in my own experiment, just with my input audio being EAC3 DD.1 instead of Dolby Atmos as you have.

Looks like we are probably both reporting the same experience. In REMUX-MODE with compliant audio there is NO AUDIBLE SOUND on the output. If instead the audio is instead RE-ENCODED on the output (manually forced or out of necessity), well now there IS AUDIBLE SOUND in the output.

Posts: 106
Joined: Sun Oct 09, 2011 2:52 pm

Re: No Audible Sound Dolby True HD/Atmos

Post by Nemesh »

All just an addition.
The BDInfo is from the retail full BD.
I work here with the movie-only version created by TsMuxer > Video, 1 Audio Track (Atmos) and 1 subtitle stream.
That one is added to with the small menu.
With both versions after conversion there is no audio.

Post Reply